Missouri Whitetails - Your Missouri Hunting Resource banner
1 - 14 of 14 Posts

·
Registered
Joined
·
31,310 Posts
Discussion Starter · #1 ·
so. i made my thread the other day about my sister flying out from PA for christmas, and I have the flu...yay. so, to top it off, my wife calls this morning at 7:30 saying come get me...the car took a dump.:mad2: so i load up ad head out to go get her. get there and pop the hood, no antifreeze at all in it. thankfully theres none in the oil. so i called and have it towd to the shop (if it wasnt 7 degrees out i would have worked on it at home). so, now i get to wait until tomorrow and see what shakes. my guesses are...blown hose (although i didnt see any bad hoses when i looked it over), stuck thermostat (easy enough), popped freeze plug (notorious on the 2.7 chrysler engines..NOT cheap) or the worst, a bad head gasket:mad2: so, here we are with company coming in and down to one freakin car...and i'm sick. gotta love it:whiteflag:
 

·
Registered
Joined
·
69,560 Posts
With the temps last night hovering around zero my guess would be a stuck thermostat. From a shop.....90% labor and 10% parts.............Can You Say....Merry Christmas Honey here is your early Christmas present.
 

·
Registered
Joined
·
1,562 Posts
Good luck man !
 

·
Registered
Joined
·
5,360 Posts
glad i have a mechanic on staff, i used to would of had to fix it right were it sit, worked on lots of trucks laying in gravel, grass etc, good luck to ya
 

·
Registered
Joined
·
31,310 Posts
Discussion Starter · #5 ·
i am the mechanic on staff..lol

if i wasnt sick, i would have tackled it myself.
 

·
Registered
Joined
·
31,310 Posts
Discussion Starter · #6 ·
Originally posted by Mailman
With the temps last night hovering around zero my guess would be a stuck thermostat. From a shop.....90% labor and 10% parts.............Can You Say....Merry Christmas Honey here is your early Christmas present.
good news is, its going to the shop i used to work at...hopefully theyll cut me some slack
 

·
Registered
Joined
·
6,049 Posts
sounds like you have my luck
 

·
Registered
Joined
·
3,431 Posts
Sorry to hear its a 2.7 sisters car popped a freeze plug that sucks. Hold out hope it could be a water pump or something else fairly easy
 

·
Registered
Joined
·
1,054 Posts
Is this on the new chrysler van? I for some reason remember you having a new dodge or chrysler van. If that is the case. that is pretty bad since its a newer van
 

·
Registered
Joined
·
31,310 Posts
Discussion Starter · #10 ·
Originally posted by Country
Sorry to hear its a 2.7 sisters car popped a freeze plug that sucks. Hold out hope it could be a water pump or something else fairly easy
water pumps on the 2.7 are the farthest thing from easy. when the w/p goes out on a 2.7 you have to pull the entire front of the engine off as the w/p is internal to the engine, driven by the camshaft timing chain. its close to an 8 hour job. when they leak, the pour water directly into the oil. been there, done that...just not on my car.

nope, not on my van, it has a 3.8. a tried and true engine thats been around forever. it has a luandry list of other problems at only 20k miles though.
 

·
Registered
Joined
·
31,310 Posts
Discussion Starter · #11 ·
oh...anywho, i went over and disgnosed it this morning, turns out its a stuck thermostat. so, i'm gonna have one of the guys over there take care of it as i'm still feelin like crap, and youve gotta pull the alternator and abunch of other stuff off to get to the t-stat. they arent fun.
 

·
Registered
Joined
·
3,431 Posts
Originally posted by Jeremy
Originally posted by Country
Sorry to hear its a 2.7 sisters car popped a freeze plug that sucks. Hold out hope it could be a water pump or something else fairly easy
water pumps on the 2.7 are the farthest thing from easy. when the w/p goes out on a 2.7 you have to pull the entire front of the engine off as the w/p is internal to the engine, driven by the camshaft timing chain. its close to an 8 hour job. when they leak, the pour water directly into the oil. been there, done that...just not on my car.

nope, not on my van, it has a 3.8. a tried and true engine thats been around forever. it has a luandry list of other problems at only 20k miles though.
Well scratch my water pump comment I was thinking you had to move a few things to get to them but didn't think it was that deep. I had a 3.0 that was like that. Glad it was just the Temro for you.
 

·
Confirmed Bachelor
Joined
·
10,482 Posts
Originally posted by Jeremy
oh...anywho, i went over and disgnosed it this morning, turns out its a stuck thermostat. so, i'm gonna have one of the guys over there take care of it as i'm still feelin like crap, and youve gotta pull the alternator and abunch of other stuff off to get to the t-stat. they arent fun.
Jeremy, hope you get to feeling better. Yeah, my truck is like that on the T-stat. I replaced it a long time ago and took me most of the day as I had to take the alternator off and a few other things. No wonder the dealership wanted something like $100 to replace it.
 
1 - 14 of 14 Posts
Top